Announcement

Collapse
No announcement yet.

Asus ROG Laptop Won't POST with New Ram Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus ROG Laptop Won't POST with New Ram Upgrade

    Own an Asus ROG GL702VSK Bios 306 Strix laptop. Upgraded the ram from Corsair Vengeance 16GB DDR4 2400 to Corsair Vengeance 32GB DDR4 2666. Laptop won't post with the 2666mhz ram installed. Power button light when pressed just keeps blinking. No fans running. Front hard drive light just keeps flashing. When I reinstall the 16GB 2400 the laptop fires right up. I want to get the 32GB 2666 ram installed and running. Do I need to update the bios to the latest 307 version? Many ppl have installed and ran DDR4 2666mhz sodimms with an i7 7700HQ processor laptop. What am I missing? Appreciate any help. Thanks

    Update: Flashed the laptop Bios to the latest version 307. Same results with the DDR4 2666 Corsair sodimms. Nada nothing......
    Last edited by BagoBones; 02-11-2019, 07:45 AM.

  • #2
    Re: Asus ROG Laptop Won't POST with New Ram Upgrade

    Originally posted by BagoBones View Post
    Own an Asus ROG GL702VSK Bios 306 Strix laptop. Upgraded the ram from Corsair Vengeance 16GB DDR4 2400 to Corsair Vengeance 32GB DDR4 2666. Laptop won't post with the 2666mhz ram installed. Power button light when pressed just keeps blinking. No fans running. Front hard drive light just keeps flashing. When I reinstall the 16GB 2400 the laptop fires right up. I want to get the 32GB 2666 ram installed and running. Do I need to update the bios to the latest 307 version? Many ppl have installed and ran DDR4 2666mhz sodimms with an i7 7700HQ processor laptop. What am I missing? Appreciate any help. Thanks

    Update: Flashed the laptop Bios to the latest version 307. Same results with the DDR4 2666 Corsair sodimms. Nada nothing......

    Hello!
    Bagobones! Did you make sure the memory was on the compatibility list on the Asus site for your laptop ? you may need to change voltage for the memory, try 1 stick at a time? I hope you didnt just buy lap top memory and assume it would be ok!!!! You may need to exchange it if so.........Also try a full cmos clear?
    Good luck!
    MSI X-99SLI
    Intel 5930K WATER
    EVGA Nilla 1080
    POWER!



    http://www.3dmark.com/3dmv/5003339

    I did this> :) Default RMA discussion banned

    Comment

    Working...
    X