No announcement yet.

IDE ATA100 Controller Card Error

  • Filter
  • Time
  • Show
Clear All
new posts

  • IDE ATA100 Controller Card Error

    Hello all,

    I am running Windows 2000 Pro and I have a Maxtor IDE ATA100 controller card and I keep getting a error with it. The error is appearing in the event log:

    The device, \Device\Scsi\Ultra1, did not respond within the timeout period.

    My machine is having little system burps. It's a nastly little problem of which I would like to fix.

    Thank you,


  • #2
    You don't say whether this is a new problem or if it has been there since installing the card. If it just occurred recently, there may be a problem with the drivers. Installing the latest version or reinstalling the current drivers may fix it. If it has happened from the beginning or after adding additional hardware, I would try moving the card to a higher slot on the mobo. If these don't work, give some more info.


    • #3
      Yes, I have the latest drivers, the BIOS is set correctly, I have Fdisk and reinstall 2K, I have the latest service pack 3, the lastest VIA drivers.

      I don't have this problem with Windows 98 or with Windows XP Pro. I don't like XP and 98 doesn't do good with it's memory management. I love Windows 2000. It's a nice system.

      The problem seem to act up after 2 months after I had 2K, I re-installed and the problem was still there. I installed XP Pro and the problem went away as well as 98. It can't be a hardware problem.

      Windows 2000 Pro does not work well with this Card. The Card has a Maxtor label on it, but the card is made my Promise, I have tried the Promise drivers as well and I still get the same error message and burps. The computer is like trying to access all of the drives at once when I insert a CD. It's strange.

      Primary Master - WD 20gig ATA100
      Primary Slave - 52x Asus CD
      2nd Master - 48x10x48 CDRW
      2nd Master Slave - 16x DVD

      Asus P3V4X Motherboard with a 866slot 1 chip. Overclock to 950mhz.
      ATI 9000pro Video Card
      512SDram PC133meg ram.

      Any thoughts?
      Thank you


      • #4
        I'm not sure what the problem is then. Is there any reason that you have decided to put the optical drives on the card? The way I would set up a system like yours is: hd on the card as primary master, cd/rw as master on the primary mobo ide, cd-rom as master on secondary mobo ide, dvd as slave on secondary mobo ide. This would: prevent the optical drives from impeding the hard drive's optimum transfer mode, allow simultaneous read/writes between the cd/rw and the other optical drives, and simultaneous read/writes between the optical drives and the hard drive.


        • #5
          I have attached the CD rom's to the MB and left the HD on the controller card. And I still get this error message and the time delays.

          My MB is a ATA66, Are the standard CD rom's ATA66? I wouldn't have any benefit running the CD rom's on the controller card, is this correct?

          If you look at this link:

          It talks about a problem that was fixed with the service pack 3 for Windows 2000. I would like to know what this is.

          This is the error message with or without the CD roms attached to the controller card.

          The device, \Device\Scsi\Ultra1, did not respond within the timeout period.

          When you setup W2K it asks you for the drivers for the controller card, I am wondering if there is a bug when you re-install a driver though the system control panel.

          Maxtor support sucks with this problem they don't have a clue. They referred me to this link:

          I am also using the round ATA100 cables for the CD rom's and HD, can this be a problem?

          I don't know about this, it's driving me nuts.

          Thank you for your help.


          • #6
            I am thinking that it is a driver problem as the hardware seems to work with other oss. The Promise link has a driver posted. Have you tried it yet? The rounded cables shouldn't cause a problem since you say they are ata100. It could be a bad cable though. Have you tried swithing the cd and hd cables? (Idon't think this is the problem though.) There won't be any benefit s from switching the cd drives to the card.


            • #7
              Thank you for your help.

              I had no problems with the cable setup when I was running Windows 98 and XP Pro. I wouldn't think it would be a Bad Cable.

              I have tried the Promise driver, I think after I first start with the Maxtor Driver on the install of Win2k, you have to hit the 'F6' button you know, and then I reinstall the Promise driver after Win2k is up and running. I think something is being corrupted with the driver install or the driver is just bad.

              I need to do a proper uni-stall of the driver and try it again.

              I laugh at the Maxtor support and with the article that they sent me, They told me that my problem was a Plug and Play error, so they sent me the information about Windows 95 and Windows NT. Dumb people.

              It has to be a Driver issue with Win2k, like you are saying.

              Thanks again.


              • #8

                I have the exact same card, driver, firmware and OS setup (W2K SP3). I was going to chuck the card because I was worried that it was damaged. I installed the drivers during setup (F6) and I have not updated them since. Unfortunately I am having the exact same problems as you. I also get "An error was detected on device \Device\Harddisk0\DR0 during a paging operation." in my system event log. The card is cheap and not necessarily built well so I would recommend not putting anything important on it. I'm thinking of chucking mine afterall because it's not worth the stress, worry, and aggravation. I find that Promise controllers are half decent and not all that bad but this version is really fit for the pit.