No announcement yet.

why is my HDD soooo SLOW??

  • Filter
  • Time
  • Show
Clear All
new posts

  • why is my HDD soooo SLOW??

    Hey guys,

    im not a pc n00b, but not exactly and expert so i need some help on this issue about my HDD ( i built the PC myself).

    I got an MSI KT3-Ultra ARU motherboard (via kt333 with promise Raid/ata133 controller)

    I also picked up a Maxtor D740X hard drive (i think they are also know as Maxtor Vipers?) anyway...its a 7200rpm ATA133.... its a 40gb.

    I hooked it up to the RAID controller as a single HDD because I was told this is the only way to support the ATA133 that my motherboard offers.

    I hooked my DVD and CDRW to the primrary IDE channel. The second IDE channel is free.

    Everything is pretty sweet --- EXCEPT for the less than stellar access times and bandwidth.... it just feels sluggish...

    in my Device Manager my HDD is recognized as "Promise 1+0 Stripe/RAID0 SCSI Disk Device"... which I *think* means it is recognized as a single SCSI hdd...

    -- so my question -- is there anything in Windows options (or in my BIOS) I should change to improve my HDDs overall performance?? --- OR --- just switch the HDD over to the normal IDE controller?? because if this is what ATA133 is, ill take ATA100 anyday!!

    --- Sisoft Sandra Pro Edition 2003 ---
    ++ File System Benchmark ++

    My HDD: 18,567 kB/s

    standardized results from sandra for comparison....

    ATA100, 5.4k RPM, 2MB cache, 30GB (NTFS): 20,000kB/s
    ATA100, 7.2k RPM, 2MB cache, 60GB (NTFS): 23,300kB/s
    ATA100, 7.2k RPM, 2MB cache, 30GB (FAT32): 24,000kB/s

    so my goddamn drive is slower than a 30gb 5.4k rpm on ATA100..... which sucks..

    --- system specs ---

    amd athlon 1800 XP
    msi kt3-ultra-aru (with raid/ata133)
    256mb pc2700 ddr ram
    maxtor d740x 40gb 7200rpm ata133 hdd
    sb audigy platinum
    sony 16x dvd
    yamaha 20x10x40 cdrw
    msi gf4-Ti4600

    WinXP Pro.


    +++ I hope I gave enough info 4 u guys to help me out....

    if u need more, just ask me.

  • #2
    [b]I hooked it up to the RAID controller as a single HDD because I was told this is the only way to support the ATA133 that my motherboard offers.
    Who told ya that crap? The VIA KT333 chipset natively supports ATA133 via it's own southbridge thought ATA133 is really only a farse as an ATA100 Western Digital "JB" series drive (8MB cache) is faster than the Maxtor and maybe the "BB" series (2MB) as well. ;)


    • #3
      maxtors..ehhh..slowyness =)

      my seagate 80 @ ata 66 on kt133 gets 25 =)


      • #4
        ok I swapped it to normal IDE... slight increase in Sandra tests... but nothing worth noting!! it still sucks!! (about 18,700)

        any ideas?


        • #5
          Well, im not sure if this is the problem, but I think i found whats wrong....

          in WinXP, my CD drives are listed as Ultra DMA Mode 2....or ATA66 i believe....

          in BIOS it says my HDD is set to U6 mode (ATA133), but WinXP says only "Ultra DMA Mode"... which i assume is U1.... or ATA33!!

 wonder my Sandra File System marks are around 17 or 18,000!!!

          i tried changing it, but cant see how you do it...

          anyone know how to change to mode U5 or U6 (ata100 or 133)???

          thanks guys...


          • #6
            XP is also known to slow the set speed of drives down itself if it has troubles gettin' info from them w/o errors. ;)


            • #7
              ok.... so how do i fix this freakin thing.... its really annoying me now....

              any help is appreaciated....

              btw... SP1 is installed, I also tried the VIA miniports that let you set to UDMA mode 6 (ata133)....well that didnt work either....the VIA prog thinks its at ATA133 but WinXP still sees it as ATA33...

              and I know its at ATA33 too because when I bench on Sandra, the max burst is always 32 or 33mb/s


              • #8
                I mangaged to get WinXP into UMDA Mode 5 (ATA 100) which I am pretty happy with.... BUT MY HDD STILL SUCKS !!

                any ideas?

                I dont know if this helps, but here are my Sandra Results...

                I have been told by some people to take Sandra's tests with a grain of salt... but I know they show an accurate picture because I did a few tests myself... on of which was a simple copy+paste of a 144MB File. It took 19 seconds to complete. That amounts to approximately 7 to 8mb per second.... thats awful....

                +++++++++SiSoftware Sandra 2003 Professional+++++++

                Test Status
                SMP Test : No
                Total Test Threads : 1
                SMT Test : No
                Dynamic MP/MT Load Balance : No
                Processor Affinity : No
                Windows Disk Cache Used : No
                Use Overlapped I/O : Yes
                Command Queue Depth : 4 command(s)
                Test File Size : 255MB
                File Server Optimised : No

                Benchmark Breakdown
                Buffered Read : 40 MB/s
                Sequential Read : 28 MB/s
                Random Read : 5 MB/s
                Buffered Write : 30 MB/s
                Sequential Write : 24 MB/s
                Random Write : 6 MB/s
                Average Access Time : 10 ms (estimated)

                Drive Class : Fixed
                Total Space : 37.3GB
                Free Space : 11.5GB, 31%


                • #9
                  as long as u have installed all your windows updates, i would next assume winxp has put this drive into "critical mode" i think thats what it was that happened with my maxtor 80Gb, it was "near death" according to winxp, but i just formatted and re-activated the drive, all is well

                  if you go into computer management, and to the section "disk management" it will list your HDD in there. down the bottom where it says Disk 0, DIsk 1 etc etc see if there is a lil yellow triangle w/exclamation mark. if so, right-click the disk and select re-activate, then its probably worth running chkdisk over the drive.


                  • #10
                    The thing is I already checked that....:)

                    thanks for the tip tho :thumb:

                    btw....incase you were wondering, its status always has been "Healthy" since I first checked it..... :confused:

                    Im TOTALLY stumped now.... I have also posted my problem on 5 or 6 other boards and everyone is clueless...

                    I think I need to take the reformat path.....

                    although i really dont want to... :no:


                    • #11
                      Just out of curiosity, have you tried a different IDE cable?


                      • #12
                        i sure did.

                        im still at a loss for what to do though.

                        i have the latest drivers for *everything*.

                        Do you think it could be a power supply problem?

                        im running Audigy Platinum with AudigyDrive (@ front of PC)
                        1 DVD-rom and 1 CDRW
                        Gf4 ti4600
                        256ram pc2700
                        msi kt3 ultra aru
                        network card
                        plus 1 or 2 other cards associated with the mobo (USB 1.1, "D" Link LED indiaction system with another 2usb 2.0 on that card)
                        one case fan (80mm)
                        one fan on cpu (80mm)

                        all sucking from a 300w psu

                        is it possible the HDD is just not SPINNING fast enough because it cant get the juice it needs??