No announcement yet.

How can I recover main BIOS from backup BIOS (Z390 Aorus Master)?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How can I recover main BIOS from backup BIOS (Z390 Aorus Master)?



    Hello!




    My motherboard is Gigabyte Z390 Aorus Master.




    I've updated the main BIOS from F11n to F11.

    Everything was fine and was able to boot into Windows.




    Later I've observed that Secure Boot was disabled and I could not enable it (as required by Win11).

    It gave me the following message:

    "Secure Boot can be enabled when Platform is in User Mode. Repeat operation after enrolling Platform Key (PK)".




    So I took the following steps:

    Key ManagementPlatform Key (PK) Update / Yes / "Success".

    After that I was able to set Secure Boot Enable as <Enabled>




    After restart, the PC went dark! It would not boot either into Windows or BIOS menu.




    I switched the BIOS button to the backup position and the PC booted normally. Now I run my PC on the backup BIOS.




    QUESTION:

    How can I recover the main BIOS from the backup BIOS?




    *Resetting the CMOS didn’t restore the functionality of the main BIOS.













  • #2
    While in back up bios main page press alt f10 should do it

    Comment


    • #3
      Originally posted by TrebleTA View Post
      While in back up bios main page press alt f10 should do it
      Hello!
      Thanks for the reply.

      As far as I know Alt+F10 resets the platform to optimal defaults, which I’ve already done multiple times in multiple ways.
      Still, I wasn’t able to boot with the main BIOS.

      Am I missing something?

      Comment


      • #4
        Originally posted by TrebleTA View Post
        While in back up bios main page press alt f10 should do it
        Hello!

        I just tried your suggestion, unfortunately, it solves nothing regarding the Main BIOS.
        (Thanks anyway).

        Comment


        • #5
          It's that or alt f12, maybe you need to be in qflash ui. I've not done it for ages but should work. It did work for me but i have not tried it on the new capsule bios

          P.s what I did was main board switches set to backup and single. Then load in to bios press alt f12 or alt f10, now go in qflash and do the same alt f10 then alt f12 wait 2 min then save an exit the bios. Then reboot back to bios then switch switch off the pc. Now Change the switch on main board to main bios other switch still on single and boot. Finger crossed it should do it.
          Last edited by TrebleTA; 12-15-2021, 05:10 PM.

          Comment


          • #6
            Originally posted by Endre View Post

            Hello!




            My motherboard is Gigabyte Z390 Aorus Master.




            I've updated the main BIOS from F11n to F11.

            Everything was fine and was able to boot into Windows.




            Later I've observed that Secure Boot was disabled and I could not enable it (as required by Win11).



            I'm having the EXACT same situation. Bump bump bump!!

            But my problem is a little different. I have the TPP enabled in BIOS but in Windows Secure Boot is "OFF" when checked at msinfo32.

            I searched how to roll back the bios in the z390 Aorus Master and every single place says "well, its just like updating the BIOS but with an older version", problem is, when I try to roll back the BIOS to any older version I get a message: "INVALID BIOS IMAGE".

            F11 seems bugged af....

            Any ideas how to roll back to a previous version?

            Thanks

            Comment


            • #7
              As stated by the bios on the gigabyte web site you can not roll back the bios from this new capsule bios. If you have problems with the new bios like secure boot, go to gigabyte e-Support and tell them only way to fix any issues with the bios.

              Also try my guide thread and look for how I enable secure boot.
              https://www.tweaktownforum.com/forum...cking-i7-9700k
              Last edited by TrebleTA; 01-21-2022, 06:27 AM.

              Comment


              • #8
                Originally posted by Rui Milk View Post


                I'm having the EXACT same situation. Bump bump bump!!

                But my problem is a little different. I have the TPP enabled in BIOS but in Windows Secure Boot is "OFF" when checked at msinfo32.

                I searched how to roll back the bios in the z390 Aorus Master and every single place says "well, its just like updating the BIOS but with an older version", problem is, when I try to roll back the BIOS to any older version I get a message: "INVALID BIOS IMAGE".

                F11 seems bugged af....

                Any ideas how to roll back to a previous version?

                Thanks
                Hello!

                There will be no rolling back to a previous BIOS version if you’ve already updated it to F11.
                It’s a security thing.

                Comment


                • #9
                  As a note Secure Boot is not required for W11 install - secure boot capable just means you have a GPT format boot drive and CSM disabled for UEFI boot and have fTPM or PTT enabled

                  Changing Secure Boot settings without following the correct steps esp. key settings often results in problems like the above.

                  Firstly only proceed if youre already running WIndows in UEFI mode with CSM disabled.
                  If the secure boot page shows mode:setup then toggle standard to custom, then custom to standard, accepting factory defaults. It will then be possible to enable secure boot if you want to.

                  Comment


                  • #10
                    Hello jwsg!

                    Yes. You’re right. I know that.
                    Unfortunately, I’ve already taken the steps that I’ve described earlier, in my primary post, and now, I can not boot with my regular BIOS anymore.
                    I’m on the backup BIOS.

                    Comment


                    • #11
                      If you want to change from UEFA to non uefi, I would set windows to boot in to safe mode, via msconfig, then go in to bios and change to non uefi, boot in to windows safe mode, then disable safe mode then boot back to windows and your now non uefi.
                      It's been a while since I did the above but use to work.
                      also you can roll back bios even from the capsule bios.
                      I use to use this way from changing fro. A raid set up to normal non raid.
                      Last edited by TrebleTA; 2 weeks ago.

                      Comment


                      • #12
                        Also if main bios is corrupt, you can flash the backup over the main bios while in the backup bios. Your have too google it. For the key command

                        Comment

                        Working...
                        X