No announcement yet.

Can not update X570 AORUS XTREME bios beyond V30

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not update X570 AORUS XTREME bios beyond V30

    Hi everyone,

    I got my X570 AORUS XTREME back on 2019 and I've been using Gigabyte's @bios to update without problems (yeah I now know). However, since I've updated to bios V30, I was not able to update to any newer versions (32, 33 and 34). Every time I do and after the update is finished and the PC restarts, it crashes immediately after the bios screen just before loading Windows. However, I'm still able to enter bios and check the version of the newly installed bios e.g. V34 and eventually erasing the newly installed bios and downgrade to V30. The PC boots normally upon this. I can also boot to Windows using the backup bios (V30) after disabling the main corrupted bios.
    I've tried updating the bios using a USB to flash the newer bios from the bios setup using Q-Flash but with no success. The same failure happens.
    I though that updating bios may corrupt something in my Windows so I've decided to set a Windows-containing-USB as the 1st boot device to reinstall Windows but the same error happens again.

    Ryzen 9 3950X
    EVGA GTX 1070
    32 GB Corsair
    Samsung SSD 970 EVO Plus 1TB

    I hope anyone can help/advice and thanks in advance.