Announcement

Collapse
No announcement yet.

Aorus B550 Elite Motherboard not detecting Wifi Adapters :(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aorus B550 Elite Motherboard not detecting Wifi Adapters :(

    Hi All,

    I built my PC a couple months ago and everything works fine so far. However, I am trying to install a Wifi/Bluetooth combo adapter on my PC. I have now tried 2 different brands and products for Wifi/Bluetooth adapters which connect to the PCIe slots on this motherboard and neither of them at any time worked or were even detected on the Device Manager.

    I installed the drivers for both of these products correctly, yet with still no success. I currently have a graphics card connected to the PCIe x16 slot which works fine, so I tried connecting the adapters to all the other PCIe slots one by one, but the adapters were still never detected. As two different products have not worked so far I would say I can more definitively say it has to do with the motherboard or PCIe slots.
    Please does anyone know why this is happening or if there is something I need to do to enable all the PCIe slots to work, or any other advice or guidance on this would be greatly appreciated!!

    Below are the different specs of my PC:


    2 Wifi/Bluetooth Adapters Used = (1) Ubit AX WiFi Card WiFi 6 Dual Band 3000 Mbps AX200 PCIE Wireless WiFi Card with Bluetooth 5.1 & (2) TP-Link WiFi 6 AX3000 PCIe WiFi Card for PC with Heat Sink (Archer TX50E), Bluetooth 5.0

    Bios Version = F1
    OS = Windows 10 - 64Bit
    Power Supply = 600W Semi Modular 80+ Bronze, GAMEMAX VP-600-M-RGB
    Storage = Western Digital 500GB WD Blue SN550 NVMe Internal SSD - Gen3 x4 PCIe
    Graphics Card = Gigabyte GeForce GTX 1660 Super Gaming OC 6G Graphics Card
    Motherboard = Gigabyte B550 AORUS Elite (AM4 AMD/B550/ATX/Dual M.2/SATA 6Gb/s
    CPU = AMD Ryzen 5 3600X 6-Core
    RAM = TEAMGROUP T-Force Vulcan Z DDR4 32GB Kit (2 x 16GB) 3200MHz

  • #2
    BIOS version F1 ?

    Latest is F11k.
    Z490 AORUS Master,
    Z390 AORUS Master
    GA-Z97X
    -SOC Force ,
    Core i7-4790K @ 4.9 GHz
    GA-Z87X-UD3H ,Core i7-4770K @ 4.7 GHz
    G.Skill F3-2933C12D-8GTXDG
    @ 3100 (12-15-14-35-CR1) @1.66V
    2xSSD Corsair Force GS 128 (RAID 0), WD Caviar Black SATA3 1TB HDD,
    Evga GTS 450 SC, Gigabyte Superb 720W
    XSPC RayStorm D5 EX240 (Liquid Ultra)
    NZXT Phantom 630 Ultra Tower
    Win 7 SP1 x64;Win 8.1 x64;
    Win 10 x64

    Comment


    • #3
      I have since updated to Bios Version F11, but my adapters are still not being recognized in any of the PCIe slots that I plug them in to.

      Comment


      • #4
        If it means anything , i have same Mobo as You and i use Asus AC56 Card without any issues. Maybe it is vendor releated ....

        Comment

        Working...
        X