No announcement yet.

ASUS Strix X470-F won't attempt to boot, or sometimes works fine

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASUS Strix X470-F won't attempt to boot, or sometimes works fine

    Having a weird issue with my Ryzen 2700x build.

    I built this in February and everything worked great for about 2 months. Suddenly one day when I hit the power button to power it on nothing happened - would not post or send power at all. The light for standby power was on, as well as the RGB shroud. It seemed like some kind of short on the board maybe?

    I "breadboarded" taking the mobo out of the case and removing everything except CPU. I used a screwdriver to short the power pins and it attempted to boot with the onboard diagnostic lights hanging at RAM. I installed RAM, diagnostics made it to GPU. Installed GPU, and got it to hang at boot. Installed boot drive, and I was back in business with a successful boot!

    Installed everything back in the case, and again no power/no attempt to boot at all. Assuming it was the case, I ordered a new one and installed.

    Same thing on installing everything in the new case, so back to the "breadboarding". This time I tested power on with the mobo+cpu+ram+gpu+boot installed but not attached to case. Success. Tested power with each screw attaching mobo to case. Success.

    It worked for a week with no trouble. Then again yesterday I went to power it on, and no power/no attempt to boot.

    Do I have a motherboard problem? one of my components? Something in my cable routing? This seems so weird.