Announcement

Collapse
No announcement yet.

Lost USB 2, then power to the computer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost USB 2, then power to the computer

    Win 10 Pro desktop with ASRock Z97 Extreme6 motherboard. Yesterday I lost the case's front USB 2 ports, but not the USB 3's (I didn't check the back USB 2 ports). Today, while trying to figure it out I mistook the USB 3 board connector for the 2 and moved it to another USB 3 port on the mobo and started up. It ran momentarily then shut down, with the red power and reset lights showing. I turned off the computer's power switch and moved the USB 3 connector back to its original spot and pressed the case start button. No power at all. My first thought was a blown fuse, but I'm not finding one on the board or in the manual. Maybe the battery? But how does it come out? I've removed the graphics card but the space is tight. Thanks,

    Follow up: it's not the battery. The only other thing I can think of, short of the PSU having crapped out for some reason, is the Thermaltake case start button. For the past several months, pressing on its left side starts the computer then it stops, while pressing on the right starts properly. I don't see a way to get to it, certainly not easily.
    Last edited by genegold; 4 weeks ago.
    ASRock Z97 Extreme6 / Intel i7-4790K
    32 GB G.Skill DDR3 2133 RAM (Ares 4x8gb)
    EVGA GTX950 SC
    Prolimatech Megahalems Rev. C cooler w/ Nexus Silent Fan
    Seasonic X650 PSU
    Samsung Pro 850 256GB SSD (system drive)
    SanDisk ExtremePro 480, Seagate 1TB, 2TB and 2x 3TB SATA 6Gb/s
    Plextor PX-891SA CD/DVD Writer/Player
    Dell U2412M Monitor (1920x1200)
    IBM Model M keyboard / Bornd M120 wireless mouse
    Thermaltake F31 Case
    Canon MP640 / Brother HL-2270DW printers
    Audio system: Dac + Powered speakers + USB card + LPS + power cond./distrib.
    Windows 10 Pro x64

  • #2
    good information

    Comment

    Working...
    X