No announcement yet.

Old asrock dr debug d0

  • Filter
  • Time
  • Show
Clear All
new posts

  • Old asrock dr debug d0

    I have an issue where one of my old PCs is not posting without pressing reset. It has been around for sometime and finally getting back to try and sort it.
    Asrock 870 extreme3 will post immediately to dr debug code d0 (every time). It can be immediately remedied by pressing reset whereupon the system will post normally, every time.
    Happens whether on first start or reboot (ie whether it is warm or not).

    What I have tried (over 2 years so may be out of order) -
    • Replaced power supply (twice) . Both seemed fine- no change in symptom.
    • Reseated/check cpu multiple times and used cpu with a different mobo with no issues. No changes to symptom.
    • reset cmos (many multiple times) replaced cmos battery, reflashed bios (this has been done using 3 different methods on asrock support page). No change to symptom.
    • Checked all connections and for hair /debris in mobo which has been removed/cleaned etc)
    • different peripherals used.
    • ensured cmos button not jammed in or anything similiar ( found someone had that issue somewhere on google).
    • Have also swapped out ram and tried different channels.
    • removed headers and just operating on mobo switches ( no changes)
    • Tried many different bios settings.
    • Used different GPU.
    • used different hdd's
    • Probably done other stuff I cant remember.
    I am using this PC as a basic storage/server and it not restarting without me resetting it can be a pain.
    Recently added upgraded to windows 10 . no changes to symptom.

    Current setup is
    • Asrock 970 extreme3 on basic bios settings
    • Phenom ii 555 black default clock, UCC off.
    • generic 8gb ram (works fine/ also tested in other PC)
    • ssd 550gb OS windows 10 (new)
    • HDD x 2 in raid 1 2tb
    • Backup HDD x 1 2tb
    • GPU is Asus GTX 660 directcu ii
    • Corsair CV650 (new)
    I am thinking about ordering a replacement bios chip but as its old I dont really want to spend any money on somerthing that wont fix it. especially since i suspect I just need to replace the mobo.

    Any insights on what the issue might be would be much appreciated.
    I would especially like to know what the differences are between a hard reset (hold power button) and just hitting reset. ie what does hitting reset actually do?

  • #2
    Think I SOLVED IT- (trust the dr debug) in the interests of someone else reading this post.
    Further to the above. Initial playing around with bios caused windows 10 to have a brain explosion and die. while trying to sort this with numerous bios changes and restarts. I found that the system began to try and post OS as normal when I had set ucc on and then turned it off again. (i turned it on and off several times to check and seems to now stay off)

    I believe my problem was the following:

    1.Basically the other (previously ok) CPU core has failed, prob due to not being that good to start with and also it being 12ish years old. (Background- phenom 555 is usually 2 core but can be set to be 3 or 4 core depending on whether you luck in a good one - they are essentially a factory second of the phenom 955 with only 2 stable cores set from factory, I had tested mine on purchase and it ran well on 3 cores at that time.

    2.I purchased a new 990fx mobo several years ago because I thought the 870 was faulty. However the 990fx motherboard used this cpu with no issues because it does not unlock cores. Therefore working fine on the 2 factory checked good cores.

    3. the 870 motherboard can unlock cores, for some reason it appears it was trying to operate the other core(s) even though the UCC setting was off.

    Thus I was getting the d0 fault. I think that pressing reset caused it to bypass the UCC and start with just 2 cores.

    Turning the UCC on and off has seemed to get it to now stay off.

    The PC has been running fine now for 24hrs.
    In an unrelated tip for those following the upgrade path from windows 7. Make sure you pause and allow your raid drives to resync in Win7 before trying to upgrade to 10. This caused me all sorts of upgrade fails until I worked it out :( .

    Hope this helps someone else.