No announcement yet.

Nvme SSD sometimes not getting detected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Nvme SSD sometimes not getting detected

    I have a system with an Asrock X99 Extreme 4 paired with an i7 6800k running for a few years with no issues. Recently I decided to upgrade my boot drive from a sata ssd to an M2 Nvme. Windows installation went well and the system was working as expected. However, after a few days I started having issues where sometimes when it boots I would get an error "No Operating System found", which was caused by my ssd not beign detected by the bios.
    At first, just restarting the computer would get it fixed, but now that doesn't work anymore. I tried removing the drive and reinserting it, and it worked, but it had to be done every boot. After some experimenting, I discovered that by just removing the GPU from the PCIe slot (which blocks the M2 slot and has to be removed to access the ssd) and plugging it back in allows me to boot (without even touching the drive at all). My best guess is that by removing the GPU it forces the bios to "recheck pcie devices" and it detects the ssd. However, this is a very tedious process to take every time I want to boot my computer.
    I should also note that after I get it to boot, I don't experience any issues whatsoever, which leads me to believe this is not an issue with the drive, but with the motherboard firmware.
    Did anyone ever experience this issue before, or have any suggestions as to what can be done to solve it?
    Thank you in advance.