No announcement yet.

X99X Fatal1ty Killer won

  • Filter
  • Time
  • Show
Clear All
new posts

  • X99X Fatal1ty Killer won

    Need some help figuring out if my MB is broken or not

    I've got a ASRock X99X Fatal1ty Killer MB and installed XPG SX8200 Pro SSD.

    Before I installed it I had the OS running on 2 Sata SSD's running in RAID 0. When the M.2 card was installed it didn't show in UEFI. I followed this guide.

    I did the following:
    - Launch Storage OpROM Policy setting to UEFI Only. As seen here
    SATA Mode should be set to either AHCI (default) or RAID. I chose RAID. As seen here
    Then saved and restart back to BIOS
    It then says that I must make sure the boot order is UEFI: <Installation Media Device Name> first and not AHCI: <Installation Media Device Name>. The AHCI did not appear but I got USB: <Installation Media Device Name> instead. So I chose the EUFI option.

    After that I saved and exited. I can also mention that I disconnected the old SSD's so the M.2 was the only one connected. When I get as far to chose the place I want Windows installed nothing appears. I've tried with SATA mode on AHCI, CSM disabled but that didn't help. Eventually I gave up and thought I'd just go back to the old SSD in RAID 0. I had deleted the RAID so build a new on using the UEFI's "easy raid installer" or what it's called. That worked and I can see them UEFI but the same problem happens when I want to install Windows. No disk are shown...

    So now I don't have any way of installing Windows... I'm leaning on just replacing the MB and CPU since the main problem and why I did want to reinstall windows was this insane boot time. After some googling I've found out that the problem might just be with the X99 plattform and it's insane long preboot. And that makes sense cause even without windows it takes FOREVER to boot to UEFI.... Bah.... I really don't want too though since I've got a custom waterloop with hardtubes which means I've gotta drain the whole system and bend new tubes for the CPU

    Any advice is more than welcome!
    Last edited by MrSpaceworld; 08-29-2019, 07:13 PM. Reason: type-o