No announcement yet.

ASRock Extreme4 970 BIOS Instant Flash not working...

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASRock Extreme4 970 BIOS Instant Flash not working...

    Iím trying to update my BIOS , but for some reason the Instant Flash wonít detect its own file. I instant Flash, It scans and shows the file, but doesnít seem to know thatís the instant flash file, (970EX2.80) and it sits there, as it just does the same thing to other non instant flash files , which I know because this USB wasnít empty the first time I tried it. I have an Asrock Extreme4 970 . I bought it used and Iíve only had it for a few months (I understand I shouldnít touch the BIOS if everything is working correctly , but the problem I have is the USBs disconnecting when there is a heavy load, specifically when using Adobe Premiere. They disconnect randomly, and thereís no way to get them back working so Iím forced to restart each time. So from my research I found updating the BIOS has fixed this for many people.) Iíve tried 2 different USB sticks and an external hardrive , and formatted both USBs over multiple times. Any help would be greatly appreciated!

    Imgur: The magic of the Internet