No announcement yet.

Z390 Taichi Error Code 99 and A2

  • Filter
  • Time
  • Show
Clear All
new posts

  • Z390 Taichi Error Code 99 and A2

    I received a new Z390 Taichi mobo from Newegg and plugged in the i9-9900k (w/cooler), RAM (supported), PSU, USB2 cable, and front panel header and failed POST with codes 99 (PCI) followed by A2 (SATA). There is nothing plugged into the PCI slots and nothing in the SATA ports. Assuming this was a mobo problem I RMA'd it back to Newegg and received a replacement board. SAME problem! Everything is brand new. I tested the PSU and it looks good unloaded. I tried single/dual ram banks in many combinations, but no change. Could this be the CPU? Could I have received 2 bad mobo's? The RMA time limit is closing on the CPU so I'd like to know how likely it is the CPU could be bad. SATA only comes from the Z390 chipset, right? PCI come from both? Thoughts on how to proceed? Thanks!

  • #2
    Re: Z390 Taichi Error Code 99 and A2

    Per a post here, the 99 code means something about PCIE (if that's an accurate reference). What type of boot drive do you have installed? Or how are you attempting to boot. And, when you say it won't post, do you see anything come up on screen? Do you see the ASRock logo or the instructions about pressing F2 to enter the BIOS or does it fail before that?


    • #3
      Re: Z390 Taichi Error Code 99 and A2

      I am booting by turning on the PSU. I have no boot drive installed (nothing plugged into either the PCI-E nor the SATA ports). Supposedly this mobo will boot up to the UEFI screen when there's nothing else to do, but the display (using the embedded Display Port) remains blank. It fails before I can do anything else. I've already RMA'd the mobo (again) and will try a 3rd one but I'm questioning whether the CPU could be the problem and not the mobo.


      • #4
        Re: Z390 Taichi Error Code 99 and A2

        Quick update.
        I verified the PSU is working by trying it in another computer.
        I verified the RAM is working by using it in another computer.
        That leaves the CPU and mobo (using the embedded graphics and no boot drive yet - it should still boot into the EUFI GUI, right?).

        I just received my 3rd mobo and tried these experiments:
        1. I powered up the mobo with nothing but the PSU and display (Display Port) plugged in. The decorative white LEDs cycle on/off but nothing else.
        2. I plugged in the CPU w/o RAM and received error codes 50 and 55 (RAM problems as expected).
        3. Added RAM and received the same 99 and A2 error codes (SATA and PCIe problems) but nothing on the display. I can't boot into the EUFI interface.

        So, I guess I'll return the i9-9900K CPU. It doesn't seem likely I received 3 new faulty mobos in a row.

        Thoughts? Could a bad CPU be causing this kind of fault?


        • #5
          Re: Z390 Taichi Error Code 99 and A2

          Update: It turns out the mobo would not talk to the Display Port on boot up but it DOES talk to the HDMI port. Once I swapped monitors BAM everything worked. I setup a few settings I found online and now it talks to the Display Port. So I'm good to go.

          How do I mark this SOLVED!