No announcement yet.

H110M-HDV bricked after internet flash

  • Filter
  • Time
  • Show
Clear All
new posts

  • H110M-HDV bricked after internet flash

    Hi, Please help me, I just bought this motherboard and with factory 1.50 bios everything was working fine but I decided to upgrade to the latest 1.80 version. After internet flash I got a message to press enter to restart but after that I just got a black screen with no signal on the monitor. It was like that for a few hours. During bios upgrade I made recovery USB (crashless feature) but it didn't help at all, so at some point I turned off the pc holding power button for some time. My motherboard is probably bricked, cpu and chasis fan spins, but power/reset buttons does't respond, usb mouse led is lighting.

    What should I do now?

  • #2
    Re: H110M-HDV bricked after internet flash

    Dear Am0eba:

    This is ASRock TSD, Bryan.

    Even though you tried ASRock Crashless function before, system is still not able to boot properly.
    I’d like to introduce the detailed steps of our ASRock CCrashless feature to you. Here is the process to recover BIOS update for your reference:
    (1) Please place BIOS file in the root directory of the USB drive.
    (2) Please install USB drive to USB2.0 port.
    (3) After powering on the system, system will automatically try to execute BIOS recovery and please wait around 3~5 minutes.
    (4) After waiting 3~5 minutes, please check if system can boot into OS or BIOS setup successfully.

    If the screen still remains black after recovering, please refer the methods as below:
    (1) Please turn off the power supply, and clear CMOS.
    You could refer P.18 of user manual for the detail process to clear CMOS:
    (2) Please re-install the memory module to the slot.
    (3) Please remain CPU and a stick of memory, and remove all the other unnecessary devices. Then boot again.

    If you have any further question, please contact us by support request form:
    ASRock > Support Request Form

    ASRock TSD