No announcement yet.

Changed motherboard, can't load drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Changed motherboard, can't load drivers

    Old motherboard died, bought and installed an ASRock FM2A88M-HD+ R2.0. Of course Windows won't load because it can't recognise the new motherboard and needs the drivers installed. Got some advice and went to the C: prompt and used the following to attempt to load the drivers:

    dism /image:C\ /add-driver:X:\ /recurse (where Driver:"X":\ refers to the location of the drivers).

    Tried to use the driver CD as the location of the drivers - no go.
    Copied the drivers to a USB and used that location - no go
    Eliminated everything on the USB but the drivers - no go

    Continually says it can't find the drivers.

    Now VERY frustrated - any ideas?

  • #2
    Re: Changed motherboard, can't load drivers

    I doubt the dism command will do what you want it to do, since it only works with .inf files. This is from a dism information page:

    The driver servicing command supports only .inf files. Windows Installer or other driver package types (such as .exe files) are not supported.

    That page:

    What was the old mother board that died?

    You may have some luck trying to start Win 7 in Safe mode, if that boots then you may have a chance fixing that installation.

    The real solution is to install Win 7 again, fresh for the new board.


    • #3
      Re: Changed motherboard, can't load drivers

      Hi Parsec,

      thanks for the advice. I'm beginning to see that re-installing Windows 7 on the HDD will be the only way to get things to work. The old mobo was a Gigabyte GA-MA790X-DS4 with an AMD Phenom triple core processor (AM2?).

      I have since managed to get another old ASUS P5KPL/100 motherboard to start up for me so I can at least use the computer again. I tried running the CD from the new motherboard with the old one and it tells me it is not for that platform.

      I might even invest in Windows 8 and be done with it.