Announcement

Collapse
No announcement yet.

ASRock Z68 Extreme3 Gen 3: Refuses to recognize SSD/HDD

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASRock Z68 Extreme3 Gen 3: Refuses to recognize SSD/HDD

    Just assembled a new rig this afternoon (many hours ago...) and I've been jammed up on trying to install Windows. The BIOS cannot seem to find any of the drives I have plugged in (an Intel 320 series 120 GB SSD and two older drives, one Seagate 500 GB and a WD 1 TB). I have tried every combination I can think of with respect to cords and power supplies. I know all the drives work because the two HDDs were plugged into my old computer and I tested the SSD on that same rig yesterday. Any tips? I've tried cycling through the different SATA modes in the BIOS to no avail.
    Last edited by Strontosaurus; 05-18-2012, 01:25 PM.

  • #2
    Re: ASRock Z68 Extreme3 Gen 3: Refuses to recognize SSD/HDD

    Can you plz be much, much more descriptive. Like I turn on the power and x happens, then, y, and get error z.

    also, plug in only things you need. for example, you only need one ssd in to install windows. you can install the other two drives later.

    Make sure SSD is in the first SATA port and your DVD in the last.

    also, watch the LED. make sure to tuen on the LED features in BIOS as well.

    -=Mark=-

    ps, what's an, "any tios"?

    Comment


    • #3
      Re: ASRock Z68 Extreme3 Gen 3: Refuses to recognize SSD/HDD

      Yeah, no problem.

      I turn on the power and it boots up to the motherboard screen. I have a few seconds to go to the boot menu or the BIOS and then it continues on to the contents of the USB flash drive, which I have formatted to boot a Windows installer. At the Windows installer, I tell it I want to do a new installation and then it tries to find a drive to install on; no matter what I have plugged in, it can't find anything.

      If instead of letting it boot normally I go to the BIOS, I cannot see any hard drives there; again, just the USB drive. I have tried plugging in three different drives, in different combinations, with different cords and in different slots.

      The motherboard LED goes through what I assume is a normal cycle, counting up to 100 and then turning off when all is well.

      Since I posted this thread, I went back and tried the hard drives on a different computer, the one in which they originally worked, and they did not show up, so I'm thinking now that I somehow burned up 3 drives at once.

      Comment


      • #4
        Re: ASRock Z68 Extreme3 Gen 3: Refuses to recognize SSD/HDD

        Oh No, I feel for you. I have had that happen many times. especially with HDDs.

        Did you try just the SSD by itself with AHCI enabled?

        If it still doesn't show up you can try Parted Magic and try to rescue it. I've done this successfully a few times.

        Make sure the system is in AHCI mode. When you turn it on, reboot, just plug the SSD cable into the sata port (Hot swapping, it only works in AHCI mode). Then it sometimes is picked up by the time Parted Magic boots. Then go to system and select erase disk then do a secure erase. It takes just a few seconds to a minute to finish.

        Parted Magic | Free software downloads at SourceForge.net

        This has saved my bacon a few times and a two or more week RMA.

        -=Mark=-

        ps. Here's link to G.Skill forums on using parted magic. This is where I originally found out about Parted Magic:
        http://www.gskill.us/forum/showthread.php?t=6829
        Last edited by MarkJohnson; 05-18-2012, 02:49 PM.

        Comment

        Working...
        X