No announcement yet.

X58 Extreme3 and SataIII SSD problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • X58 Extreme3 and SataIII SSD problems

    I recently purchased a crucial 64g c300 so use as my boot device on my asrock x58 extreme3 board. I have it connected to the marvell sata3 controller and am experiencing problems.

    During unpredictable times both in my installation of windows and (now that i have completed an install on the 8th try) I am experiencing problems within windows itself.

    Occasionally the device becomes unresponsive, upon a reset, i can enter bios and see that its no longer listed. If i power off and back on, it appears again, then after some time it will go away.

    within windows i am seeing freezes and messages along the lines of [windows cannot continue, the device has become unresponsive].

    I am coming to the conclusion that either the ssd or the motherboard is faulty. I could test on sata2 to try and pinpoint, but regardless i bought this drive for sata3.

    I am hoping someone may have some advice on how i could try to narrow the problem and determine which if any of my hardware may need replaced. Is there any ssd test software provided by crucial?

    I have tried different sata cables and tried both sata3 ports. I have also tried 3 OS's for what thats worth.

    Thanks in advance.

  • #2
    Re: X58 Extreme3 and SataIII SSD problems

    you say you have tried different SATA cables. Where they SATA 3 cables? There is a difference between Sata 2 and 3 cables. This is why My Asrock X58 Extreme board came with both kinds of SATA cables. I am not saying this is the issue. You might put another HD on a SATA 3 channel to see if it is always recognized by the BIOS. If solid it would rule out the motherboard, I think. Just thinking here. Other possiblity is the power cable is flaky.