Announcement

Collapse
No announcement yet.

Problem with PCI-E card

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with PCI-E card

    I recently installed an ATI Radeon HD5450 in an ASRock 945GCM-S. The video card doesn't seem to be detected since I can't get any input from it to my monitor. The onboard video continues to work. Any ideas on how I can disable the onboard video and get the card to work?

    I have the latest version of the BIOS (P1.20) and I tried changing a couple of the options in the BIOS (even though the card should be automatically detected).

    Thanks in advance.

  • #2
    Re: Problem with PCI-E card

    I have the same issue but with a Radeon HD5670, was reading on other forum that I need the bios version 1.21, but cant find it anywhere.

    Comment


    • #3
      Re: Problem with PCI-E card

      Here is the link to the Ars Technica forums, were they posted the beta bios, it does work as i am now enjoying the HD5670, thanks to CBerSK for the tip, really thank you bro :D

      PCI-E card not detected - Ars Technica OpenForum

      I will keep a copy of the Bios and the .txt in case anyone else needs it and until they post it officially here.

      Comment


      • #4
        Re: Problem with PCI-E card

        I have the same issue. Apparently, the link that the above user provided for the 1.21 BIOS is no longer valid. Can anyone send me the 1.21 BIOS for ASRock 945GCM-S? The latest BIOS on the ASRock website is still 1.20

        Thanks!

        Comment


        • #5
          Re: Problem with PCI-E card

          http://rapidshare.com/files/43280013...45GCMS_121.rar

          There, i put it up on rapidshare.

          The .rar contains:
          .txt with detailed instructions
          .iso that is seemingly empty, but after burned on a cd will work properly as a boot disc with the bios updating tool, and the actual 1.21 beta bios.

          Comment


          • #6
            Re: Problem with PCI-E card

            Muchas Gracias, revdarian! i'll give it a try as soon as possible.

            i don't think any of us consumers knew that PCI-E 2.1 would have compatibility issues with PCI-E 1.0 motherboards. it took us all by surprise!

            Comment


            • #7
              Re: Problem with PCI-E card

              all right! thanks a bunch. it worked great!

              my Radeon HD 5670 is now working in 945GCM-S after the 1.21 beta bios update. I was told by ASRock support that there was no way to get the 5670 working. I guess there is some mis-communication going on between the europe/america/asia teams

              Comment


              • #8
                Re: Problem with PCI-E card

                Glad that it helped you too.

                The Europe Team is the one that provided the beta bios, hopefully the other teams will get the memo about it's existence.

                Comment


                • #9
                  Re: Problem with PCI-E card

                  Originally posted by Revdarian View Post
                  http://rapidshare.com/files/43280013...45GCMS_121.rar

                  There, i put it up on rapidshare.

                  The .rar contains:
                  .txt with detailed instructions
                  .iso that is seemingly empty, but after burned on a cd will work properly as a boot disc with the bios updating tool, and the actual 1.21 beta bios.
                  Hi Revdarian. I know this is a three months old thread, but I can't find the 1.21 BIOS Update anywhere. Would you kindly upload the file again, maybe on Mediafire or Megaupload? The Rapidshare link doesn't work anymore.
                  Last edited by mcastilloy2k; 02-26-2011, 11:23 AM.

                  Comment


                  • #10
                    Re: Problem with PCI-E card

                    http://rapidshare.com/files/44987076...45GCMS_121.rar

                    Up it is again :) cheers

                    Comment


                    • #11
                      Re: Problem with PCI-E card

                      Originally posted by Revdarian View Post
                      Thanks!!!

                      Comment


                      • #12
                        Re: Problem with PCI-E card

                        I need the 1.21 BIOS Update for the ASRock 945CGM-S motherboard. Please post it somewhere it won't get deleted and we can all get to it. Thank you in advance.

                        Comment


                        • #13
                          Re: Problem with PCI-E card

                          Originally posted by clongtwik View Post
                          I need the 1.21 BIOS Update for the ASRock 945CGM-S motherboard. Please post it somewhere it won't get deleted and we can all get to it. Thank you in advance.
                          I don't have any account on a permanent host, so that will have to fall on your end.

                          I have just reposted it at this rapidshare link:
                          http://rapidshare.com/files/45519179...45GCMS_121.rar

                          If you know of a permanent host or anything similar, feel free to put it up and link it here for the community :)

                          Comment


                          • #14
                            Re: Problem with PCI-E card

                            Good day, everyone. I'm Zean, and I'm new here.
                            I, too, have a problem with my 5750 working with my ASRock Wolfdale 1333 D667. The card is not detected. I tried disabling onboard graphics and updated the bios to 1.50 to no avail. Tried to download that 1.21 bios from rapidshare but I can't. An error pops up when I click download. Is there any other site where I can download that and try it? Thank you very much.

                            Comment


                            • #15
                              Re: Problem with PCI-E card

                              https://rapidshare.com/files/4601603...45GCMS_121.rar

                              Dude, find out a place that can keep that file forever and upload it there, rapidshare deletes it each couple weeks and i won't be around forever.

                              Comment

                              Working...
                              X