No announcement yet.

845pe chipset with ICH4 SouthBridg Install trouble

  • Filter
  • Time
  • Show
Clear All
new posts

  • 845pe chipset with ICH4 SouthBridg Install trouble

    I hav bought a new Gigabyte Mobo with intel 845pe chipset it has a ICH4 southbrige that control's the first 2 ide channels & promise raid 20276 chip runing as ATA not raid .My trouble is i tried to install Mandrake 9 and it didn't seem to register my ide chanels with my harddrive and cd rom the h/d is master on ide1 and cd-rom master on ide2 ,i have a burner installed on the promise ata chanelas master ,I have the bios set to boot A,CD on ide2 ,H/D on ide 1.When i put in the install cd in cd on ide2 it starts to load then stops with a mesage cannot read from cd/rw whitch is my promise ata chanel, So i put the boot cd in the cd/rw and continue install i start going through the setup then when it's time to set the mount point it cant find my Harddrives and asks what driver to load for scsi adapter .Ime not sure if i need a certain linux driver for the ICH4 chip to load as the scsi adapter ,there is a list of drivers to choose and i tried most of them ,then it asks what parameters to pass to the kernal.I am a newbe to linux and dont know where to go from here .i have no trouble instaling mandrake 8 or 9 on my other pc but its old and slow.Any sugestions ,Guides or links would help alot and be greatly appreciated thanks.P.S would i also need drivers for the AC97 sound Intel Pro/100 ve network adapter?

  • #2
    It's a little lat but I may be able to help if ya still need it.

    First, remove any CD-ROMs or Burners from the Promice controller. They are unable to reliably support ATAPI devices such as CD-ROMs. I've found that Linux is less forgiving on that. That's why it tells you that it cannot read from cd/rw. It's strange that you put the install CD in your regular drive and it said it can't access your CD-RW. I say remove one of those drives and only give it the choice of one.

    So you're gonna have to have a hard drive and a CD-ROM on the ide channels.

    Next issue is that it didn't register your ide channels? I guess the question I have is: did the bios recognize these drives. If it did then Linux should be good.

    Lemme know if you still need help.



    • #3
      AC97 and Intel Pro/100 are well supported under linux and there will be kernel modules (drivers) supplied with mandrake 9.


      • #4
        Sorry i havn't replied earlier but my apendix burst and i was in hospital for near 2 weeks.
        Ok to clarify the problem i am having isn't with the ICH4 chip (thanks Bern)i just realised that is the AC97 and USB controller .
        My problem is how to setup the raid array as an extra 2 IDE channels not Disk mirroring os striping.I have windows installed and it has no problem recognising all devices .To recap i have H/D's on IDE1 Master & Slave A Master Boot DVD on Ide2 & my burner on the raid channel .I would prefer to have all my Os's running on 1 drive as my drive 2 is for backups and downloads.
        I dont have a third H/D to put on the raid channel and need to have the cd-r & dvd as master so i con copy on the fly under windows.
        I can install Mandrake 9 with no problem if i disable raid in the bios and install but when i enable it in bios linux crashes with errors,I cant remember the errors as i have removed that Partition i will reinstall this weekend and post the error msg.
        I have read people have enabled ATA on the raid channel so it recognises H/D's & CD-Roms but they had to recompile the kernal or somthing this at the momn't is a bit daunting for me .
        Thanks for the replies i will post the errors soon as possible.