Announcement

Collapse
No announcement yet.

pegas.usb

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pegas.usb

    Ok, before I start rambling I'll let you all in on the fact that I'm new to linux and have pretty much no idea what going on ! Be prepared for a dumb arse question !

    I recently installed redhat 7.2 with both KDE and Gnome (still to decide which is better). Now I'm trying to figure out how to install my pegas.usb chipset based modem (aztech um9800). I've downloaded rpm's from aztech but am a little unsure how to install them, and then how to use the modem.

    I think I've got the rpm's installed :?: :?: but I dunno... The hardware browser says the modem is there (listed under system devices I think) but it can't find it when I try to configure a net connection.

    So, how do you install rpm drivers ? And how do you install usb devices, such as a modem. Dumb arse question I know but if you can gimme a url (that's useful) or some hints / tips I'd be most greatfull.

    Thanks !

    :confused: :hammer:

  • #2
    Linux USB info,
    Linux-USB project: http://www.linux-usb.org
    Linux USB Guide: http://linux-usb.sourceforge.net
    Linux-USB device overview (working devices and drivers): http://www.qbik.ch/usb/devices/

    [edit]This particular page has information you will need : http://www.linux-usb.org/USB-guide/x332.html
    And have a look at /usr/src/linux*/Documentation/usb/acm.txt, if you don't have anything in /usr/src/linux* you'll have to install the kernel src rpm's from your RedHat cd's.
    p-two.net

    Comment


    • #3
      Right this next link seems to have some info on getting this modem going,
      http://www.modem-help.freeserve.co.u....html#winmodem
      p-two.net

      Comment


      • #4
        Originally posted by Bern
        And have a look at /usr/src/linux*/Documentation/usb/acm.txt, if you don't have anything in /usr/src/linux* you'll have to install the kernel src rpm's from your RedHat cd's.
        nope nothing there. So how do I install these files ? Do I run the installation again or is there another way ? If there are only a couple of files should I just copy them myself from the cd ? If so, what are the files ?


        Man I dunno squat about all this linux stuff, it's making me feel pretty stoopid ! Oh well...

        :snip:

        Comment


        • #5
          First of all you need to find out exactly what kernel you have now, do "uname -a" and you'll see soneting like this,
          bash-2.05$ uname -a
          Linux tbird 2.4.16 #2 Tue Nov 27 09:00:12 EST 2001 i686 unknown
          The bold part is your kernel version,next you look on the cd(s) for kernel-source-*version*.i386.rpm where *version* matches your kernel. Install with "rpm -Ivh kernel-source-*.i386.rpm" as root and then have a look in /usr/src/linux.
          p-two.net

          Comment


          • #6
            k, coolies. Will do.

            Thanks for yr help !


            ok, place bets can I get this right or wil I have to come running back ?!

            Comment


            • #7
              Originally posted by FrodgE
              [B]ok, place bets can I get this right or wil I have to come running back ?!
              What odds are you giving? :smokin:
              p-two.net

              Comment


              • #8
                lol, not very good actually ! (depending from which way you look at it !)

                I tried installing the kernel source as you said but it had problems with dependancies. Since I didn't really know what I was doing or where to find the rpms it needed I just went and upgraded my installation so it would install everything it needed. I think that's all ok now. :?:

                The URL you listed that goes through the install process seems only to be relavent for AMR modems, however it looks like it may also compile stuff for USB as well. Dunno, no idea ! Problem is that when I try to do a rebuild as the instructions say it just comes up and says it can't find the file (which is bollocks 'cas i can see it right in front of me). Will a corrupt rpm cause this error or am I just doing something wrong ??

                Comment


                • #9
                  Linux is case sensitive so if you don't type the file name exactly it will complain.
                  Try "rpm -rebuild slmdm-2.03-01.src.rpm"
                  p-two.net

                  Comment


                  • #10
                    yeah I know that one but I'm pretty sure that ain't it. Even though it's case sensitive it doesn't appear to matter when changing directories ?? :?:

                    If I do "rpm -qlp slm..." it lists the contents and complains about the file size. If I do --rebuild, it claims it can't find the file. It's not to do with re-typing it differently 'cas I just pressed the up arrow to get the previous command then edited the rpm switch. Think the rpm file is stuffed ? It seems ok, but at the same time it doesn't !

                    Comment


                    • #11
                      Try downloading it again. I don't have rpm on slackware so all I can do is bust the packages and look at the contents.
                      p-two.net

                      Comment


                      • #12
                        ok, getting now...

                        Is the souce code for Mandrake, SuSE and Redhat different / compatible ? I notced they have 3 different source code rpms. One for mandrake, another for suse, and a 3rd for 2.4.x.

                        Since I'm running RH should I be using the 2.4.x or would it make no difference ?

                        Comment


                        • #13
                          Get this one, "slmdm-2.03-01.src.rpm", it seems to be the most generic one available, you also might want to grab any redhat ones you see but leave the mandrake ones as they probably won't be compatable with a red hat kernel.
                          p-two.net

                          Comment


                          • #14
                            Yep that's the one I've started trying to use, however the bloody thing STILL won't rebuild for me. I've got no idea what I'm doing wrong, everything looks just fine to me.

                            It's screen capture time ! What am I doing wrong ??? I can't pick it.

                            Comment


                            • #15
                              I use rh71 ..
                              to install a rpm
                              su
                              password

                              rpm -ivh (filenamecasesensitive)

                              now if you com across active libs you can do this:

                              rpm -ivh -nodeps (filenamecasesensitive)

                              that will allow you to install the rpm even if there are dependancy issues.

                              now to see if you actually have it installed and where it is :

                              updatedb
                              locate (filename)

                              in this case do not type the whole file name as it is in the rpm instead jsut use a protion of the file.. example: i just installed:

                              libssl.s0.0.9.6.rpm and i wanna see where it installed to i would type :

                              locate libssl | less

                              this will tell me where it is.. and what version it is..
                              some of your results will be really really long that is why we pipe it with less.

                              anyways i hope this helps..
                              loopy:wave:

                              Comment

                              Working...
                              X