No announcement yet.

LILO Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • LILO Problems

    Ok, heres the deal:

    Finally got around to setting up me old 4gig hdd last night and whipped out the Slakware 8 isos and booted. Installed Slak and a whole swag of other goodies onto the 4gig. Easy peasy.
    Buuuuuut (theres always a but isnt there?)

    When I got to the LILO setup menu, I said to install LILO into the superblock of the 4gig hdd (as my winxp install is on my primary hdd and i dont want lilo raping it) as per the fabulous instructions at the slakware site. Lilo dumps me back at the main menu with an error saying it cant do that task. (cant remember the exact wording, this was all happening at 3am mind you)
    Not having a floppy drive, I had to skip the lilo install process.

    So this morning when I fire up me beast to get back into it, I cant run lilo config, or the setup program and get back to that stage of the game. The only way i can see is re-installing all the linux files again and possibly getting the same error result

    So is there some trick to get back to that stage?
    ive yet to boot into linux because theres no boot loader (well there is- one from an old mandrake install but it bombs out after showing that lovely boot manager screen)
    so i cant post any configs or anything. (or can I?)

  • #2
    Download tomsrtbt, creats a boot floppy following the instructions and use that to boot your slack install, then you can create a boot floppy with the slack tools or with something like mindi linux.


    • #3
      Hmm, well I dont use, or plan on using a floppy drive in my computer anytime soon, so fixing it with a floppy disc is out of the question. That, and I dont have a floppy disc drive anymore....

      Anyhoo, I fixed it early yesterday. I took the hdd out, removed my 40gig, attached the 4gig (linux drive) as master, loaded up my custom win98 boot cd and nuked the MBR on the linux drive. Re-partitioned it, plugged the 40gig back in, and installed Slak8.0.

      Was all fine and well until I tried booting from the 4gig. It would kernel panic and crash out on me. So off I go to the Slak Book and read up on dual booting. I grabbed the first 512bytes of the linux drive, slapped it into an image file and added it to my winxp boot.ini.

      Now I can finally dual-boot WinXP & Linux.

      yay for me.

      See my other thread re:customising slak