No announcement yet.

Ciberlink PowerDVD doen't work.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ciberlink PowerDVD doen't work.

    I just got a new computer (DELL Precision) and I got it with a DVD Player and Ciberlink PowerDVD already install on it.

    When I play any DVD on it it goes to the "DVD menu" inside the disk (not the player menu) and when I click start... It starts and most of times on few seconds, sometimes in few minutes it will go back to the main menu of the movie.

    -I tried diferent DVD's and I got the same results I even tryed new one.
    -I tried to see if it was something on the configuration of the player and I found nothig.
    -I uninstall cyberlink and not even Windows Media player wouldn't play the movie.
    -I install it back and I got the same results but at least the Windows Media player would play the movie.

    So it look's like the decoder of Ciberlink works and the drive is fine but the rest of the software have some glich.

    I looked for the revision of the software and it says Rev AO1 and when I look on the internet I found things for Rev4 & 5 but nothing for this Rev., I don't know if it's to new or I got old software on a new computer.

    Anyway I need help.

    Dell tech suppot doesn't know what to do.


  • #2
    Re: Ciberlink PowerDVD doen't work.

    If the machine is brand new, then tell Dell not to worry about what is wrong with it, just fix it. They're highly praised for their tech support... tell them to put their money where the mouth is. It it highly likely that it was a botched install of the OS (they use images of the OS to install on a given line of machine, not clean installs for each box), so it shouldn't be your problem to have to fix.
    Old age and treachery will overcome youth and skill
    My Toys