Announcement

Collapse
No announcement yet.

Help with Ultra DMA Mode!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with Ultra DMA Mode!!!

    I can't activate UltraDMA and my HD is sooooooo slow.

    In "Device Manager", 'IDE ATA/ATAPI controllers' it says "DMA if available, but in "Current Transfer mode" it says "PIO mode"

    My HD supports UltraDMA, but I don't know the UltraDMA Mode and PIO Mode in the BIOS to activate it.

  • #2
    A little lax on the system specifics here, but if you have a newer mainboard with the Phoenix/Award BIOS, then you might have some luck looking under the "Integrated Peripherals" header. Many will have an OnChip Functions sub-header where you can set the board's ability to utilize UDMA drives to their fullest.
    Old age and treachery will overcome youth and skill
    My Toys

    Comment


    • #3
      I had a similar problem with my "on the board" IDE controller that my DVD and CD-R were connected to. Initially it worked fine, but after a couple days I noticed my CD-R would not record any faster than 8x. I checked the settings and sure enough, it said PIO mode, even though the DMA if availible was selected. I then found the Microsoft Tech Article below, and by removing the IDE controller from the device manager and allowing it to re-install, I then changed both to PIO Only Mode, and then Re-opened Device Manager and set to DMA mode, and it worked.


      http://www.microsoft.com/hwdev/tech/storage/IDE-DMA.asp

      Hope this solves the problem for you,

      J.Roberts

      Comment


      • #4
        If you have an optical drive on the channel with the hard drive you may also see this problem.

        Comment

        Working...
        X