No announcement yet.

Hi boys can you help bios prob

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi boys can you help bios prob

    Hi boys,
    My name is Katrina, kat for short can you help with a bios problem? My mobo is the MSi Pro2 RU. Two questions really.
    I have tried to update my bios from the basic comes with motherboard to a later version v3:1 do you have to update incramentally? ie 3:1 3:2 3:3 or can you update to the latest version? I updated to 3:1 and received the "Pass" message re booted and found the following message CMOS/GPNV checksum bad? any ideas as to what this means I have been to the Msi website and received no help. I can get into the bios to alter settings but, the operating system reports none system disk?
    Further examination reveals that windows is present but the partition has been removed.
    I am puzzeled over these issues as in the past I had an Asus mobo and flashing the bios was easy.
    I tried the live update feature that came with the software but it did not work the button was missing off Msi website so, I opted to flash the bios via the floppy method which is what is required for the lower versions of bios update.
    Help !!
    What would you boys advise?

  • #2
    Hi Kat, and welcome to TweakTown. :D

    As for the BIOS questions, you do not have to update the BIOS incrementally as the latest version will have all previous BIOS revisions incorporated in it. Just get the most recent update and Flash away.

    As to the other problem, I have never heard of a BIOS Flash moving/removing a partition, but who can say. I had posted in another thread that it is many times necessary to format/reinstall the OS after a Flash, but here's something to try just for grins and giggles...

    I am assuming here that you have the K7T266 Pro2-RU motherboard since it was the one readily found on the MSI website

    Many times when you start getting reports that the hard drive cannot be found, it is a problem with the motherboard's IDE driver set. Sometimes, this can be fixed by installing the VIA 4-in-1 drivers fresh. This may or may not work for you, but it's worth a shot.

    More likely, though, your motherboard's Flash has made changes in the way that your hardware communicates with the Operating System. This is why it is necessary to format/reinstall the OS fresh after a BIOS update.

    I'm not familiar with the MSI line of motherboard, but I have had BIOS Flashes end up in a similar state that yours did, and the fresh install of the OS fixed things right up.

    Check around on the Checksum error, though. I never received this particular error and can't say for certain if it is connected with the failure to report the hard drive or not.

    Good luck! :)
    Old age and treachery will overcome youth and skill
    My Toys


    • #3
      Thankyou for your reply
      Darthtanion, I never had problems like this with the Asus boards you could flash the bios and restart and go back into windows. Seems a pain to re format the drive each time the bios is updated.
      I,m currently running an old tx qdi board that has never given me any problems apart from being out of date.

      Anyway, thankyou and i will try what you have suggested.

      Kindest regards


      • #4
        In regards to the checksum error.. I had the same problem with my MSI K7T Pro2-A board just recently. I'm not actually sure that it was CMOS that was having the problem. because it was around that time that I found out my CPU was dead.. It would last about 15 seconds when I booted and then froze.. So I'd get far enough to see 'CMOS checksum error - using defaults' which didn't actually do anything...


        • #5
          Bios update seemed to go fine
          the only real concern that I have is why it cannot re start windows. The Bios reports the correct hard drive all functions in the bios appear to be correct except when I had the drive on the raid it failed to show up you know the little fasttrack counter at the begining? so I transfered over to ide I then did an auto check for hard drive in the bios and it identified it correctly yet when I re start I get the message none system disk!! I looked at the disk partition and found that acording to fdisk no partition exists. I'm not sure why updating the bios should remove the primary dos partition? strange hmmm then I think perhaps Msi boards might be strange?

          I have left a post for Msi regarding this issue and have asked if they can come up with a more safer way of updating bios.
          thanks Beefy for your reply I have plenty of cooling inside mobo it has five fans a bit noisey though!!
          if anyone else has any more thoughts on this issue I would be greatful for all information


          • #6
            Thats a strange problem indeed.

            Another possibility is that you got hit with that virus that reformats your c: when you restart. My mate got hit by that just recently.

            Anyway, in future bios updates, id simply unplug the hdd. "Just in Case"
            Then plug in back in after the flash has completed.

            Let us know if MSI get back to you, id be interested to see what they have to say about it.


            • #7
              Darthanion, first of all, the BIOS kicks in before the OS starts up, as does the disk boot procedure...So, the issue with bad interaction between the BIOS and the OS, is highly unlikely, because the OS hasn't started yet.

              My bet would have to be that there is an error in the hard disk controller handling routine of the BIOS, so the disk is not read correctly when boot is attempted. I think the disk is OK...

              The checksum error, could very possibly mean that the BIOS file was corrupt.

              Kat, I think you should get the very latest BIOS, flash once more via a dos boot disk, reboot, enter CMOS and load defaults (just to clear any stray strings that may have been left behind) and then boot normally.


              • #8
                OK... let's see if I have this straight...

                You were running a RAID before the BIOS was Flashed, and then after the Flash you couldn't boot up? And then you tried to use the hard drives on a regular IDE channel?
                Old age and treachery will overcome youth and skill
                My Toys


                • #9
                  I have the same board and when I flashed I just had to reconfigure the bios.... Just go in to the bios and chose the option for high performance and tone it down from there


                  • #10
                    I think Darth's just hit this one on the head..

                    Are you saying that you had the drive running in a RAID config, or you just had it on the RAID controller?

                    If you had it in a RAID config with another drive, then when you flashed the BIOS, chances are you lost the RAID setting information, so it didn't work properly.. The drives by themselves can't be read normally, so that's why nothing showed up when you put it on the normal IDE channel..

                    But if it wasn't part of a RAID set, then I'm stumped.. something could have happened from it being on the RAID controller when you flashed, but I don't see why it would..


                    • #11
                      Probably because two of the BIOS updates available on their site had improvements (modifications) to the RAID capabilities of the board. On my old Abit board, I did the Flash, but at least they put a notice on their BIOS page that said that you'd lose the RAID info after the Flash.
                      Old age and treachery will overcome youth and skill
                      My Toys


                      • #12
                        My goodness you have all been busy!!!
                        You will be supprised by the outcome of the problem.
                        I re flashed the Bios to the latest version in this version they included a compatability resolved issue to do with Scsi drives i have a Scsi drive installed as well as raid and, it turns out to be a compatibility problem between Raid and Scsi.
                        Microstar did not get back to me so I'm dissapointed with them but, thank you all for your most helpfull advise. To be on the safe side when I re flashed the Bios I took out the Scsi card and re booted without any problems.
                        To conclude the os would not start because of the Scsi v Raid compatability problem the new updated Bios fixed this problem. I did not mention to you about the Scsi card because it was not that hard drive that I was booting from it was the one on the Raid that is why I tried to switch the drive on the Raid to IDE because I thought the Raid was not functioning properly (it did not show on Boot up) despite being configured in the Bios.

                        I suppose one day perhaps in a dream all components will be compatible straight off. Years ago the only thing we had to watch was making sure the ide cables were the right way round!!!

                        when I walked into my local computer shop guys had lists asking will this work with my mobo? to the technician.

                        Thanks again boys
                        now I have a working computer thanks to your input Kat


                        • #13
                          Glad its all working :)

                          Dissapointing MSI didnt email you back. They usually have pretty good customer support. Oh well, cant win em all