No announcement yet.

Strange Numbers In CPU-z

  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange Numbers In CPU-z

    I have an Asus Sabertooth X79 board with an Intel i7 4820k CPU and I had won a bunch of RAM through a silent auction, it was 8, 4GB (brand new still sealed in their clamshell packages) sticks of Kingston Hyper X DDR3-2400 for a total of 32GB and after checking the board found that it could run it using the XMP profile. It starts up just fine and it gives me the option to run it at 2400 in the BIOS so I set it and rebooted my system. It came up without any trouble at all. I opened CPUI-Z and and it shows that it's running in tri-channel mode which was strange because it shows that every DIMM has RAM. I went and installed Speccy and it says the same thing except that I only have 24GB installed. I also looked in the BIOS and it shows the full 32GB and that it's running at 2400 just as it should. So I went and checked to see if their was a new BIOS and there was so I flashed it thinking it just wasn't reading it right. I check in the Windows system folder and it shows 24GB instead of 32GB (Running Windows Pro 8.1). I went through the process of trying each stick in each DIMM (what a pain) to see if there was an issue with the board or the RAM but they all worked just fine. I mixed them up putting them back in and it still tells me that it's running in tri-channel mode. What am I missing here I was thinking about getting some RAM that runs at 1866 and leaving it go at that. Any suggestions sure would be helpful.

  • #2
    Re: Strange Numbers In CPU-z

    First, the Asus Sabertooth X79 specifications rate the board's memory speed as 1866 maximum:

    Asus Sabertooth X79

    Why that is, I don't know, but I've noticed that Sabertooth boards tend to have lower maximum memory speed specs.

    If you check the board's memory QVL: Motherboards - SABERTOOTH X79 - ASUS

    ... you'll see that some memory up to 2400 is included. But notice on the right of the column headings, the number of DIMMs that may be used with a particular model of memory. As the memory speed increases, fewer models can be used with 8 or even 6 DIMMs. Even at 1866, most models listed can be used with only four DIMMs.

    It sounds like the memory you got at auction were all single or maybe dual DIMM packages, is that right? If so, they are not a quad channel matched set, which also makes it harder for them to work together at the maximum supported speed. Frankly, you're lucky they work as well as they do, given random single or pairs of DIMMs.

    What you can try with the memory you have, to get it all recognized, is lower the speed. As a test, manually set the memory speed to 1600 or 1333 with all the memory timings and voltage on Auto to make it easy for it to work. If it all is recognized in Windows, great, you can then try to increase the speed one step at a time (1333 to 1600, 1600 to 1800/1866, etc) until you get missing memory again. Whatever that speed is, the max speed you can use is one step below it. After that you can set the memory timings from Auto to the values shown in the CPU-Z SPD tab for whatever speed you can use. It seems like 2400 with 8 DIMMs is to much to all work together fine.

    Also, when using all the memory slots, the CPU's memory controller will likely need a boost in voltage. This is not the same as the memory voltage, which may also need to be increased if it is currently at 1.5V. I'm not sure what your BIOS calls that setting, could be System Agent or something else. Check your manual or the Asus forum for your board for more information.


    • #3
      Re: Strange Numbers In CPU-z

      Parsec, I switched out to some DDR 3 1866 RAM from Patriot that I completely forgot that I had. With the updated BIOS all I did was choose the XMP setting then rebooted and now everything is being recognized as it should all 32GB running in quad channel mode. I went to the Asus website and found the QVL I saw that it was different from what the manual had for the memory and what slots the sticks should be installed in for best performance. I had to zoom in on the PDF file in order to read it as the text was impossible to read due to it having such small text. No problems now and I pushed the CPU up to 4.4 and it worked fine, even stayed fairly cool but I dropped back to its default speed since it's plenty fast enough at that point. Thanks for your help.