Announcement

Collapse
No announcement yet.

Can't get AHCI to work on SATA3_5 with 990FX Fatal1ty Killer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get AHCI to work on SATA3_5 with 990FX Fatal1ty Killer

    It was time to clean my case/mobo then test some cheap SSDs in RAID 0. My boot drive was on SATA3_3 and performed well but I had to move it to put the 3 Intel 520s in ports 1-3. My WD hard drive was already in port 4 so I left it there and put my boot drive in port 5. Bad move, I'd forgotten that port 5 is shared with e-sata. My PC booted up well enough and performance was OK but sequential read/write on the boot disk was way down. Samsung Magician tells me that AHCI is deactivated.

    OK, I swapped the WD and Samsung 840 Pro over so the WD is on port 5, set the 840 Pro as Boot#1 on port 4 and started the PC but Windows Boot Manager is confused and won't use it. I've tried various things; Combined Mode, e-SATA enabled and so on. I even tried switching to RAID mode and having the 840 Pro as a single disk array, but no go. The PC will only boot with the 840 Pro in port 5.

    Has anyone had this problem and solved it?

    Cheers
    Steve
    Last edited by KiwiSteve; 12-02-2014, 04:34 AM.
Working...
X