No announcement yet.

Urgent Help!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Urgent Help!

    I recently installed the new 4in1 drivers, and now my CD Writer and my CD drive are not detected in widows. They are both on the same IDE cable, set as secondary master and slave.

    They have been working fine, until recently. I think it stopped working after i installed the latest 4in1s.

    At boot up it list my 2 primary devices fine (Hard Drives).

    Secondary Master : None
    Secondary Slave: Asus CD

    The master should show my other CD drive.

    In Windows under system there shows a problem with my:

    (!) Secondary IDE Controller (dual fifo)

    I have tried unistalling the drivers and installing back the old versions, and i still have problems!

    Can someone PLEASE help me!:confused:


    VIA Apollo 133
    Pentium III 600
    256MB RAM
    Geforce 2 MX
    Win 98

  • #2
    Go to and grab the latest IDE drivers. Just get these individually and not the full set. Then install them and see if everything works again.
    Old age and treachery will overcome youth and skill
    My Toys


    • #3
      Do you mean from here:

      Ive tried downloading:

      3.14 IDE miniport driver

      Is this the driver you mean?

      Im still having problems with it though.


      • #4
        If I recall correctly with Win 98 you should use the native Windows driver - try running the minport driver installer again, this time choose uninstall.
        The reason a diamond shines so brightly is because it has many facets which reflect light.


        • #5
          The VIA drivers override the native Windows drivers.
          Cameron "Mr.Tweak" Wilmot
          Managing Director
          Tweak Town Pty Ltd


          • #6
            I tried that and it did work, although my CD Writter was still undetected, and sometimes it detected normal CDs as audio CDs :o(



            • #7
              Darn, I've had this same problem with the VIA 133A chipset and Win 98SE.
              Can't remember exactly how I resolved it though.
              If you refer to the VIA Driver Installation Guide you will see that the IDE miniport driver should not be installed under Windows 98.
              As I stated I can't remember the exact sequence I used to fix the problem.
              Personally, I don't feel there is anything to be gained by using 4in1 drivers beyond the 4in1429v with the OS and chipset you are using. As is often the case, it is ignored when VIA states that if you aren't experiencing problems, don't upgrade the 4in1's. (though I do understand that attitude is hardly sporting:laugh: )
              A couple of options here that might work.
              First uninstall the VIA 4 in1's.
              Make certain that the drives on the secondary IDE are configured to autodetect in the BIOS.
              Run a Windows setup (back up that data first, just in case).
              DL the 4in1 driver version 4in1428(a) or 4in1429 maybe as high as 4in1432 - but I seriously doubt you will gain anything from the latter.
              Install the IDE Filter Driver, AGP Driver, Via Inf Driver,IRQ Driver. Leaving the IDE Miniport uninstalled.

              Or you could try uninstalling the IDE Miniport Driver, and removing the Secondary IDE controller and wrestling with your system till you get it back. (no fun there at all)

              Anyway you cut it though, your system and driver files will probably end up a mess by the point it gets sorted out.

              Wouldn't by any chance be about due for a clean install would you? Probably your best bet in the long run, and then reinstall drivers using the time-tested reccomended install order.

              Sorry, Trancer I have been through this, and if there is an easy fix, I don't know what it is - as I remember it I hassled with it for a while, then just got severe.
              The reason a diamond shines so brightly is because it has many facets which reflect light.


              • #8
                Ummm, to me the problem looks like it's way back with the bios setup. No wonder windows isn't working too well. Drivers won't do much good if the hardware isn't detected properly. The very first step would be to ensure that the bios correctly detects your drives.

                List of things to check:
                - That the bios has the Secondary Master set as "enabled" rather than "not available" or something that means the same thing.
                - That the jumpers on the drives are correct (ie one as slave, the other as master)
                - That the IDE cable is plugged in properly and around the right way
                - That the power cable is attached properly and isn't dodgy (I've had problems with dodgy power connectors before)
                - It's also often recommended that the "master" drive be attached to the END of the IDE cable and the "slave" be attached to the middle

                The above may be considered really obvious, but it's often the obvious that we tend to overlook.



                • #9
                  I agree with everything you said FrodgE.
                  But the problem that Trancer is experiencing is one I have had myself due to the VIA IDE Miniport driver.
                  Of course, if the items on your list aren't setup properly, no driver in the world is going to help.
                  I've even had the same thing occur when upgrading the 4in1's.
                  The reason a diamond shines so brightly is because it has many facets which reflect light.


                  • #10
                    Run a Windows setup (back up that data first, just in case).
                    Howd you mean?:?:

                    When i uninstall all the 4in1s the CD ROM works temporarily, but the CD Writter doesnt, it just seems to be completly off. Ive checked the cables and BIOS settings.

                    Still having problems


                    • #11
                      Originally posted by Trancer
                      At boot up it list my 2 primary devices fine (Hard Drives).

                      Secondary Master : None
                      Secondary Slave: Asus CD

                      The master should show my other CD drive.
                      Are you still having a problem with this though ???

                      If so, fix this first then think about windows and the 4 in 1. Unless this is fixed up, your are wasting your time trying to get windows to do anything intelligent (hmmm, could even say that when the bios is ok !). THE 4 IN 1 DRIVERS WILL NOT FIX BIOS ISSUES !!!!!!!!!!!!!!! Therefore no VIA driver or patch will suddenly make your harware detect.

                      If the BIOS is going along just fine now and ALL drives are being detected but windows is still having problems then check in device manager if there are any resource conflicts with the device you mentioned.
                      (!) Secondary IDE Controller (dual fifo)
                      If not, try deleting it then restart so it'll redetect and hopefully reinstall it properly.

                      Also with the 4 in 1, unless you have new hardware or a new OS there is absolutely no point in upgrading the drivers. I'm sure Tweak will correct me if I'm wrong here but really the 4 in 1 is only updated to support new chipsets and new OS. Sure, after the first release for a particular OS / Chipset there may be some bug fixes for a few driver releases afterwards but for older systems there is no point. The drivers that are actually installed are the same ones, just distributed in a different package.


                      • #12
                        Yes i am still having problems with that. At start up it doesnt detect my CD writter. I checked the jumpers are set correctly, and the current set up has been working up until now, i think when i installed the new 4in1s, not too sure. I also installed the 4 way interleaving thing for Via chipsets.

                        My BIOS settings seem ok i think, it does read on the first option however:

                        Primary Master: 98754 (or whatever for 10GB hard drive)
                        Primary Slave: 23789 (or whatever for 2GB hard drive)
                        Secondary Master: None
                        Secondary Slave: None

                        When i press enter on the None parts it just takes you to a menu to detect if theres a hard drive there.

                        Any ideas??



                        • #13
                          Is there an AUTO option for the Secondary master and slave in your BIOS? That should be your best bet for a CD device.
                          For an AWARD BIOS you would go into Standard CMOS Setup, arrow down to your Secondary Master, then use Page Up - or Page Down until AUTO appears. Do the same for the Secondary Slave. Then save changes and exit.

                          As for what I meant earlier, I was referring to running a Windows setup to overwrite the IDE Miniport with the native Windows driver.
                          The reason a diamond shines so brightly is because it has many facets which reflect light.


                          • #14
                            just for something different too, disconnect your ASUS CD and try your troublesom cd drive on that IDE connection.. make sure of course that you set it to slave if you need to...


                            • #15
                              Well after trying everything suggested I think ive found the problem.

                              I put the CD Writter in my bros machine and it didnt even want to get past the start up screen, it wouldnt detect the drive.

                              Then i put his CD Writter in my machine, my computer detected it fine.

                              Therefore it must be that my cd writter is broken! :cry:

                              So now ive put my writter in my computer and left it unplugged so that at least i can get the CD ROM to work.

                              How can it just break? its only about 5 months old and only been used a few times. I bought it as liquidation stock on ebay so i dont know wether theres a garantee.